PHP 5.5 wordt de standaardversie voor onze Linux-hosting

php-logoGoed nieuws: sinds enkele dagen bieden we PHP 5.5 standaard aan voor al onze hostingpakketten. Deze nieuwste versie van PHP werd in 2013 gelanceerd en is een stuk stabieler dan alle vorige versies. We zijn daarom verheugd om deze nieuwe versie ook standaard aan te bieden voor alle websites en subsites die vanaf nu aangemaakt worden.

Wat moet ik doen om PHP 5.5 te gebruiken?

U hebt de mogelijkheid om in My Combell de PHP-versie in real-time aan te passen naar PHP 5.5. Dat kan u trouwens selecteren voor elke subsite apart. Opgelet: u dient uw PHP-scripts mogelijk hier en daar aan te passen indien u met verouderde code zit. Op de website van PHP.net (http://be.php.net/manual/en/appendices.php) vindt u info over de migraties van PHP 5.x naar PHP 5.5 en van andere versies. Bespreek dit zeker met uw webontwikkelaar alvorens een wijziging door te voeren. Wij raden u aan om een tijdelijke subsite aan te maken op PHP 5.5 met een kopie van uw website om de nodige tests uit te voeren.

Volgende zaken worden in PHP 5.5 niet meer ondersteund: Magic quotes, register_globals, register_long_arrays en ‘call-time passing by reference’.

Wat indien mijn applicatie niet geschikt is voor PHP 5.5?

Geen nood. De oude PHP-versies blijven actief. Werkt een pakket niet op 5.5, downgrade dan naar 5.4 of 5.3. De versies 5.2 en 4.4 bestaan nog steeds, maar worden afgeraden en zullen in de toekomst logischerwijs niet langer aangeboden worden, omdat ze een beveiligingsrisico vormen. Neem contact op met onze supportafdeling voor meer advies.